Intermittent 502s

Incident Report for Flatfile

Resolved

Flatfile experienced an issue maintaining database connections via a proxy which led to service degradations whereby some connections from the app to the database unexpectedly hung up, returning a 502 error to the client. The connection issue with the proxy was resolved at 11:47am MDT.
Posted Mar 25, 2025 - 11:27 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 25, 2025 - 10:53 PDT

Investigating

We are seeing some intermittent 502 errors when loading Portals and performing some actions inside spaces. Our team is investigating this currently.
Posted Mar 25, 2025 - 09:18 PDT
This incident affected: Flatfile Platform (Spaces).