Service disruption in EU & UK

Incident Report for Flatfile

Resolved

The issue has been resolved
Posted Aug 11, 2025 - 01:50 PDT

Monitoring

A fix has been rolled out and are monitoring results
Posted Aug 11, 2025 - 01:46 PDT

Identified

The issue has been identified and fix is being rolled out
Posted Aug 11, 2025 - 01:37 PDT

Investigating

We are currently investigating reports of a service degredation on our EU & UK platform region
Posted Aug 11, 2025 - 01:36 PDT
This incident affected: EU Regional Platform (EU Spaces, EU Dashboard).