Unable to access platform.flatfile.com

Incident Report for Flatfile

Postmortem

Incident Overview

Nature of Incident: Incorrect Application Frontend Container Deployed to Platform Frontend

Services Affected: Flatfile Platform Dashboard and Spaces

Details of the Incident

At approximately 4:26pm MDT on June 3, a tag collision caused an image for an unreleased product to be deployed in place of the Platform frontend container. This led to frontend assets for an incorrect frontend application to be served in place of the Flatfile dashboard. 8 minutes later the engineering team was alerted to the incident and manually deployed the correct image to resolve the issue.

Impact Assessment

The incident affected all users of the Platform frontend applications for approximately 20 minutes. The API was unaffected.

Root Cause

The root cause was a collision in tagging on images within the Flatfile image registry.

Resolution

Flatfile engineering manually deployed a known good image to the frontend service to immediately restore service. Following this, the image registry was patched to prevent future incidents.

Security and Data Integrity

Please be assured that this incident did not compromise the security or integrity of your data. Our commitment to data protection remains a top priority.

Posted Jun 03, 2025 - 16:17 PDT

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 15:53 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2025 - 15:40 PDT

Investigating

We are currently investigating an issue causing users to not be able to access platform.flatfile.com.
Posted Jun 03, 2025 - 15:36 PDT
This incident affected: Flatfile Platform (Dashboard).