Intermittent job failures

Incident Report for Flatfile

Resolved

As a result of a traffic spike the database connection pool was overwhelmed. We will be updating our rate limiting algorithm to account for this particular type of traffic.
Posted Mar 06, 2025 - 10:45 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2025 - 09:49 PST

Investigating

We are seeing these errors start to recur, investigating now!
Posted Mar 06, 2025 - 09:26 PST

Update

We are continuing to monitor for any further issues.
Posted Mar 06, 2025 - 09:12 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2025 - 09:12 PST

Investigating

We are seeing some jobs intermittently fail, like file extractions. We are investigating now.
Posted Mar 06, 2025 - 08:57 PST
This incident affected: Flatfile Platform (Platform API, Spaces).