Increased Number of 400 Errors

Incident Report for Flatfile

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 10:53 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 08:49 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 06, 2025 - 08:44 PST

Update

We are no longer seeing these errors however we are continuing to investigate the cause.
Posted Nov 06, 2025 - 08:24 PST

Investigating

We are currently investigating an issue where some users are seeing an increased number of 400 errors from the API with the message "remaining connection slots are reserved for roles with the SUPERUSER attribute".
Posted Nov 06, 2025 - 07:44 PST
This incident affected: Flatfile Platform (Platform API).